A high severity vulnerability (CVE-2021-44228, CVSSv3 10.0) impacting multiple versions of the Apache Log4j 2 utility was disclosed publicly via the project’s GitHub on December 9, 2021. This vulnerability, which was discovered by Chen Zhaojun of Alibaba Cloud Security Team, impacts Apache Log4j 2 versions 2.0 to 2.14.1. According to the developer, version 1.x of Log4j is not susceptible to this vulnerability. The vulnerability allows for unauthenticated remote code execution.


As per Apache Log4j (https://logging.apache.org/log4j/2.x/security.html), all log4j-core versions >=2.0-beta9 and <=2.14.1 are affected.


  • The FlexDeploy application (Tomcat and WebLogic) and its plugins do not include any log4j-core jar files, hence it is not susceptible to this vulnerability. 
  • Additionally, the FlexDeploy Tomcat distribution does not include log4j-core jar files. 
  • A few customers use Oracle WebLogic as the application server for FlexDeploy, and Oracle Support (https://support.oracle.com/epmos/faces/DocumentDisplay?id=2827611.1) has indicated that the Oracle WebLogic Server does not require patching for this vulnerability. 
  • It appears that the upgrade of Java to 8u191 or higher helps mitigate this situation, but it is not required for FlexDeploy. 
  • Customers are advised to look into any custom developed plugins, scripts and other products that are used in conjunction with FlexDeploy for this vulnerability as well.